同時リクエストが立て続けに発生すると、リクエストが途切れるまでアプリケーションロックが解放されず、その間、Accel Documentsの機能が利用できなくなります。

 
【発生条件】

同時リクエストが多発している場合に発生します。

【原因】

クライアントから処理要求を行うとセッション取得処理が行われますが、セッションの一貫性を担保するためにアプリケーションロック取得処理の呼び出しを行っています。
このアプリケーションロック取得処理の呼び出しに問題があり、大量の同時リクエストが発生した場合にデッドロックしたような状態になってしまっておりました。

【対応方法】

製品の不具合となります。
下記のアップデートを適用してください。

・intra-mart Accel Documents 2014 Winter (ver8.0.3) 以降にアップデートしてください。

【回避方法】

アプリケーションロックは、リクエストが一定時間途切れることで解除されます。
アプリケーションロック取得中にサーバーを停止した場合など、アプリケーションロックが残ってしまった場合は、Accel Platformの「システム管理 」→「アプリケーションロック一覧」から「acceldocuments-(テナントID)」のアプリケーションロックを解除してください。

-- 対象 ------------------------------------------------------------------------
iAP/Accel Applications/Accel Documents/2013 Autumn
iAP/Accel Applications/Accel Documents/2013 Spring
iAP/Accel Applications/Accel Documents/2014 Summer
--------------------------------------------------------------------------------

FAQID:520
この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています
Powered by Zendesk