intra-mart Accel Documents において、Internet Explorerでファイルがダウンロードできない事象が発生します。

【事象】
・PDFファイル
  ファイル名をクリックすることでファイルを参照することが出来ます。ダウンロード時にはエラーが表示されます。

・Excel・Word・Powerpointファイル
  ファイル名をクリックしてもエラーメッセージは表示されません。ファイルを参照することも出来ません。ダウンロード時にはエラーが表示されます。

【条件】
以下の条件に当てはまる環境の場合に発生します。

・HTTPSを利用していること。
・クライアントによらず発生します。
・Chromeでは問題が発生しません。
・「Accel Documents - 8.0.1-PATCH_002」適用後に発生。

【原因】
Accel Documents 8.0.1-PATCH_002の修正が影響している可能性があります。
SSL通信時に「Cache-Control: no-cache」が指定されているとInternet Explorer側の問題によりキャッシュファイルが作れずこの事象が発生する可能性があります。

【対応方法】
以下の対応で事象が回避されるかご確認ください。

1. acceldocuments.properties.xmlに以下の設定を追加します。
- <entry key="kiun.repository.web.http.header.cacheControl"></entry>
2. resinサービスを再起動します。
3. 現象が改善されるかどうかを確認してください。

上記対応でも事象が改善されない場合には、以下の設定もお願い致します。

1. acceldocuments.properties.xmlに以下の設定をさらに追加します。
- <entry key="kiun.repository.web.http.header.pragma"></entry>
2. resinサービスを再起動します。
3. 現象が改善されるかどうかを確認してください。


-- 対象 ------------------------------------------------------------------------
iAP/Accel Applications/Accel Documents
--------------------------------------------------------------------------------

FAQID:463
この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています
Powered by Zendesk