intra-mart Accel Documentsを利用していたユーザを削除したら、文書/フォルダ一覧が表示できなくなりました。

【発生条件】
削除されたユーザが作成者または更新者となっている文書が存在していることが条件です。

【原因】
文書/フォルダの一覧および操作履歴で表示する作成者、更新者などのユーザ名を取得する際に、intra-mart Accel Platformのマスタデータからユーザが見つからないときに例外をスローしてしまっているためです。
この場合は削除されたユーザによるオブジェクトであると判定処理する必要がありました。

【対応方法】
製品の不具合となります。
下記のアップデートを適用してください。

・intra-mart Accel Documents 2013 Autumn (ver8.0.1) 以降にアップデートしてください。

【回避方法】

削除したユーザと同じコードのユーザを再度登録します。
削除したユーザーのコードは以下のフォルダ配下に出力されているエラーログで確認可能です。

RESIN_HOME/webapps/imart/WEB-INF/log/product/acceldocuments/exception/

(例) エラーログに、「log.message=ユーザ 'kn_user:aoyagi' が見つかりません。」
と出力されていれば、'aoyagi'の部分が削除されたユーザのコードになります。


-- 対象 ------------------------------------------------------------------------
iAP/Accel Applications/Accel Documents/2013 Spring
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FAQID:505
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