PostgreSQL利用の注意点を教えてください。

PostgreSQL のJDBC ドライバはバックエンド (PostgreSQL) のバージョンが 7.3 以降の場合、接続時に必ず set client_encoding = "UNICODE" を発行するようです。 
PostgreSQL 7.4.13 からは変換できないバイト列をすべてエラー扱いするようになっているため データベース側のエンコーディングに UNICODE (UTF-8)以外を使用している場合、エラーが発生する可能性がございます。 
(例)エンコードをEUC-JPで以下の文字がエラーとなります。 
~-


-- 対象 ------------------------------------------------------------------------
iWP/Webシステム構築基盤/WebPlatform/AppFramework
--------------------------------------------------------------------------------

FAQID:286
この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています
Powered by Zendesk