intra-mart Accel Platform 2015 Winter アップデート版以降を利用している状態で、intra-mart Accel Collaborationのアンケートを利用している場合、アンケート作成画面等から印刷プレビュー画面を表示し印刷を行うと、DirectMessageの宛先も印刷されてしまいます。

【発生条件】
下記のアップデート版を利用しているときに発生します。

・intra-mart Accel Platform 2015 WinterのIMBoxを利用していること
・intra-mart Accel Collaboration 2015 Winterのアンケートを導入していること

また、操作ユーザが個人設定-IMBox(チャット)の設定にて宛先ユーザ一覧の項目が「表示する」設定とされていることが条件になります。

対象画面は以下となります。

・アンケート作成画面 - 印刷プレビュー - アンケート印刷画面
・アンケート編集画面 - 印刷プレビュー - アンケート印刷画面

【原因】
印刷プレビュー画面にチャットの表示を制御する処理が含まれていないためです。

【回避方法】
以下のいずれかの方法にて回避できます。

1.個人設定-IMBox(チャット)の宛先ユーザ一覧の項目を「表示しない」に変更してください。
(ログインユーザごとの設定になります。)

2.下記設定ファイルの値を追加し、環境の再起動を行ってください。
(サーバ全体の設定となります。)

  (1) 環境を停止します。
  (2) 下記の設定ファイルに対し、設定値を追加し保存します。

  WEB-INF/conf/imbox-chat-target-config/imbox-chat-target-config_default.xml

■設定箇所

 <deny>
  <path>/tenant/.*</path>
  <path>/user/.*</path>
  <path>/ui/message/.*</path>
  <path>/imbox/frame.*</path>
 </deny>

<deny>の値に以下の設定値を追加します。

  <path>/enquete/master/print</path>

  (3) 環境を再起動します。

設定に関する詳細は下記のドキュメントをご確認ください。

http://www.intra-mart.jp/document/library/iap/public/configuration/im_configuration_reference/texts/imbox/imbox-chat-target-config/index.html

-- 対象 ------------------------------------------------------------------------
iAP/Accel Applications/Accel Collaboration/全バージョン
--------------------------------------------------------------------------------

FAQID:587
この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています
Powered by Zendesk