5.1から6.1へバージョンアップしてデバックサーバで動作させようとするとBapiControllerでエラーが発生します。

【原因】

原因は、Ver.5.1 から Ver.6.1 にかけて SAP関連のモジュールのファイル名および構成が以下のように変更されたことが影響しています。

Ver.5.1.x:imsap_connect.jar 

Ver.6.1.3:im_sap_connect.jar, im_sap_bapi.jar 

eBuilderのプロジェクトのビルドパスに、古い imsap_connect.jar が含まれてしまっていることで今回のようなエラーが発生致します。

尚上記jarファイルは、Ver6.0で変更されているため Ver5.1 → Ver6.0でも同様にエラーになります。

【対処方法】

対処方法は以下の通り、imsap_connect.jarを削除してください。

1.eBuilder を起動 

2.ナビゲーター・ビューを開く 

※ナビゲーター・ビューが表示されていない場合、 

以下の手順で表示 

i) メニュー[ウィンドウ]-[ビューの表示]-[その他] を押下 

ii) 表示されたダイアログ上で、[一般]-[ナビゲーター] を押下 

3.対象のプロジェクト内の以下のファイルが存在するか確認 

%PROJECT%/webapp/WEB-INF/lib/imsap_connect.jar 

4.存在する場合、そのファイルを削除 

5.デバックサーバを起動し、正常に起動することを確認

-- 対象 ------------------------------------------------------------------------
iWP/エクステンションシリーズ/eBuilder
iWP/エクステンションシリーズ/IM-ERPリアルコネクト
--------------------------------------------------------------------------------

FAQID:109
この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています
Powered by Zendesk