バージョンアップ前に登録してあった一部のポートレットが、ポータル表示時にエラーが発生して表示されません。

 
【発生条件】
V7.0までのポートレットで、以下のページ種別のポートレットをV7.2にバージョンアップした場合に発生します。
・Presentation Page
・im-JavaEE Service Framework
・Internet
・メニューリンクセット

【原因】
ページ種別のキーと設定ファイルに指定されたポートレット名のマッピングが間違って登録されているためです。

【対応方法】
使用しているデータベースに対して、下記のSQLを実行することで事象が改善します。

-----
update b_m_portlet_info set portlet_name = 'imart.PresentationPagePortlet' , entity_id_prefix = 'imart|PresentationPagePortlet' where page_kind = 'pagebase';
update b_m_portlet_info set portlet_name = 'imart.RssPortlet' , entity_id_prefix = 'imart|RssPortlet' where page_kind = 'rss';
update b_m_portlet_info set portlet_name = 'imart.JspPortlet' , entity_id_prefix = 'imart|JspPortlet' where page_kind ='jsp';
update b_m_portlet_info set portlet_name = 'imart.InternetPortlet' , entity_id_prefix = 'imart|InternetPortlet' where page_kind = 'internet';
update b_m_portlet_info set portlet_name = 'imart.JavaeeFwPortlet' , entity_id_prefix = 'imart|JavaeeFwPortlet' where page_kind = 'framework';
update b_m_portlet_info set portlet_name = 'imart.MenuLinkSetPortlet' , entity_id_prefix = 'imart|MenuLinkSetPortlet' where page_kind = 'menu';
-----

-- 対象 ------------------------------------------------------------------------
iWP/Webシステム構築基盤/WebPlatform/AppFramework
--------------------------------------------------------------------------------



FAQID:435
この記事は役に立ちましたか?
1人中0人がこの記事が役に立ったと言っています
Powered by Zendesk