IMBox を利用している環境で system.log に [E.IWP.IMBOX.COMMON.00008] または [E.IWP.IMBOX.COMMON.00005] などのエラーが出力されています。

 
【現象】
IMBox を利用している環境で system.log に以下のエラーメッセージが出力されている。

・[E.IWP.IMBOX.COMMON.00008] MessageColumnFamilyに値が存在していないか、論理削除されています。入力値 [threadId:xxxxx]
・[E.IWP.IMBOX.COMMON.00005] UserColumnFamilyに値が存在していないか、論理削除されています。入力値 [userCd:xxxxx]

【原因】
Apache Cassandra のデータに不整合が発生している可能性があります。

【対応方法】
以下の2つを実施することで改善する場合があります。
いずれか1つを実行することでも、改善する場合があります。

1. Apache Cassandra のデータのリペアを行う。

    1-1. すべての intra-mart AccelPlatform を停止します。
            Apache Cassandra サーバへのアクセスを遮断するために停止します。

    1-2. すべての Apache Cassandra サーバが起動していることを確認します。
           起動していない場合は、すべての Apache Cassandra サーバを起動してください。
           Apache Cassandra サーバが1台の場合は、停止状態でも問題ありません。

    1-3. すべての Apache Cassandra サーバで以下のコマンドを実行します。

               %CASSANDRA_HOME%/bin/nodetool repair -pr

           なお、Apache Cassandra サーバが1台の場合は以下のコマンドでも上記コマンドと同様の処理が行われます。

               %CASSANDRA_HOME%/bin/nodetool repair

    1-4. Apache Cassandra サーバが停止状態の場合は、起動します。

    1-5. すべての intra-mart AccelPlatform を起動します。

2. データ再構築ジョブネットを実行します。

    2-1. https://www.intra-mart.jp/document/library/iap/public/imbox/imbox_specification/texts/base/federation/jobscheduler/index.html#jobnet-data-rebuild

-- 対象 -------------------------------------------------------------------------
iAP/Accel Platform/全アップデート
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