【発生条件】
インターネットアクセスできない場合に発生します。
【原因】
imm ファイルエクスポート時に不正な xml がモジュールに含まれないようにするために検証を行っています。
この検証を行うにはインターネット接続が必要となりインターネット接続が行えない環境では、
通信のタイムアウトが発生するまで待機するため、xml の数に応じてエクスポートに時間を要し、エクスポートに失敗します。
【回避方法】
imm ファイルのエクスポート時に利用する .ebuilder-export.xml に、以下を設定を追記いただくことで、imm ファイル作成時に xml のフォーマットチェックを行わない設定が可能になります。
-------------------------------------------------------------------------------
<build>
<plugins>
<!-- 追加部分 - ここから -->
<plugin>
<groupId>jp.co.intra_mart.maven</groupId>
<artifactId>check-xml-format-plugin</artifactId>
<version>1.0.0</version>
<configuration>
<execCheck>false</execCheck>
</configuration>
</plugin>
<!-- 追加部分 - ここまで -->
-------------------------------------------------------------------------------
-- 対象 -----------------------------------------------------------------------------------------------
iAP/Accel Extensions/intra-mart e Builder for Accel Platform/全アップデート
---------------------------------------------------------------------------------------------------------
FAQID:1394
インターネットアクセスができない場合に、 imm ファイルエクスポートに失敗します。
