Resinが起動しない、または再起動を繰り返します。原因と対処法を教えてください。

 
【現象】
<%RESIN_HOME%>/resin-data/ 配下の *.db ファイルの一部が破損し、不整合が発生すると、Resinが正常に起動しない場合があります。
また、不整合がある場合、Resinのヘルスチェックにより再起動されることがあります。

【発生条件】
この事象は、Resinの起動時に *.db ファイル内の破損したデータにアクセスした場合にのみ発生します。
起動時に破損箇所へアクセスしなかった場合は、Resinは正常に起動します。

【原因】
*.db ファイルの一部が破損し、不整合が発生していることが原因です。

不整合が発生している場合、以下のようなログが出力されます
・ WarningService: Shutdown: caucho.database.corrupt[****/resin-data/app-0/XXXX/*.db] 
Table[data:6,****\resin-data\app-0\XXXX/*.db]: inode block 1ab8 has invalid block code (X) expected (X)

破損の原因は主に次の2つです。

1. 古いResinを使用している場合
Resinの内部データベースはバージョンアップごとに改善されており、特に Resin 4.0.63 では大幅な修正が加えられています。
そのため、古いバージョンを使用していると、*.db ファイルが破損するリスクが高くなります。

2. Resinを正常に停止していない場合
強制終了などにより、*.db ファイルが破損し、不整合を起こす可能性があります。
例:
・Javaプロセスを強制的に停止(例:kill コマンド)
・Resinの停止前にOS側から停止処理が実施された場合

Resinを正常に停止していない場合、起動時に以下のようなログが出力されます。
・ Table[stat_name:2,d:\resin-pro-4.0.XX\resin-data\app-0\XXXX\*.db] validating indexes due to unclean shutdown.

このログは、Resinが正常にシャットダウンされなかったため、内部データベースの整合性を検証していることを示しています。

【破損防止のための推奨対応】
破損を防ぐためには、以下の両方を実施してください。

1. Resinの最新版へのアップデート
Resinの内部データベースは、バージョンアップのたびに改善されています。
特に Resin 4.0.63 では、大幅な修正が加えられました。
2025年10月時点での最新版は Resin 4.0.67 です。
そのため、可能な限り最新バージョンの利用を推奨します。

2. Resinの正常な停止
Resinの停止は、以下の公式手順に従って行ってください。
■ intra-mart Accel Platform セットアップガイド - 6. Web Application Server の起動・停止
https://document.intra-mart.jp/library/iap/public/setup/iap_setup_guide/texts/start_end/index.html

【事象発生時の対応】
<%RESIN_HOME%>/resin-data/ 配下の破損した *.db ファイルを削除してください。
ただし、以下の点に注意してください。
・~data.db と ~name.db は必ずペアで削除してください。(例:log_data.db と log_name.db)  
  片方のみ削除すると、Resinが起動しなくなります。
・必ずResinを停止した状態で行ってください。

<%RESIN_HOME%>/resin-data/ 配下のファイルを削除した場合の影響については、以下のFAQを参照してください。
■ %RESIN_HOME%/resin-data/app-0/log/ のディレクトリを削除した場合の影響について
https://product.intra-mart.support/hc/ja/articles/13073810018713

■ resin-dataディレクトリ配下のファイル削除する場合、考慮することはありますか?
https://product.intra-mart.support/hc/ja/articles/27440329270169

-- 対象 ------------------------------------------------------------------------
iAP/Accel Platform/全アップデート
--------------------------------------------------------------------------------

FAQID:1412
この記事は役に立ちましたか?
1人中1人がこの記事が役に立ったと言っています
Powered by Zendesk