弊社では以下の事象を確認しております。
【事象】
1. 印影などのiframeを利用した画面のロードが完了せず、「Please wait」というメッセージが表示されたままの状態となる。
2. 詳細画面などの、ポップアップを利用した画面のロードが完了せず、「Please wait」というメッセージが表示されたままの状態となる。
【原因】
1. 印影iframe画面
・シーケンス
1. 画面呼び出し
2. iframe画面の表示
3. iframe画面をtargetにしたフォームのsubmit
・原因
Google Chrome 32では、2の読み込み中に3が実行された場合に、2の処理しか行われなくなる。
2. ポップアップ画面
・シーケンス
1. window.openによる新ウィンドウ生成と指定ページの読み込み
2. 新ウィンドウをtargetにしたフォームのsubmit
・原因
1の新ウィンドウ生成時に時間がかかった場合、指定ページの読み込み前にsubmit処理が実行されてしまい失敗する。そして、指定ページの読み込みだけが行われる結果となる。
【回避方法】
Google Chrome 32をお使いの場合は回避方法はありません。現状の回避方法としましては以下になります。
1. 他のブラウザを使用する。
【対応方法】
本件は以下の要件で修正されました。
要件 [24985] GoogleChromeにおいて、IM-Workflowの画面が表示できない場合があります。
修正されたバージョンは以下です。
intra-mart Accel Platform 2013 Summer(パッチを適用)
intra-mart Accel Platform 2013 Autumn(パッチを適用)
intra-mart Accel Platform 2013 Winter(パッチを適用)
intra-mart Accel Platform 2014 Spring 以降
-- 対象 ------------------------------------------------------------------------
iAP/Accel Platform/全バージョン
--------------------------------------------------------------------------------
FAQID:372
Google Chrome 32でIM-Workflowの詳細画面や印影が「Please wait...」と表示されたままになります。